Tech Note 1294 Detail

Error message "Package is invalid. Details: Could not unzip extension" on Chromebook

Affected Products:

PS-2400 SPARKvue Site License

Problem/Symptom:
When installing SPARKvue on a Chromebook, the following error message appears at the top of the browser window:

Package is invalid. Details: "Could not unzip extension"

PASCO Solution:

Note: Current versions of Chrome OS (35+) do not seem to throw this error anymore.

Note: The SPARKvue app for Chrome should be installed from the Chrome Web Store. Installing manually from a flash drive is not recommended.

  1. Open the Chrome browser
  2. In the URL search tab enter: chrome://flags
  3. Press CTRL-F and search for the word "zip"
  4. Look for the Chrome flag labeled "Disable the new ZIP unpacker".
  5. Enable the flag
  6. Restart the Chromebook
  7. Install SPARKvue from the Chrome Web Store

Related Technotes:
TechNote 1256 SPARKvue for ChromeOS is not installing.

Creation Date: 11/16/2015
Last Modified: 11/18/2016
Mod Summary: